Does MetaMask support Polkadot?

Polkadot blockchain is not an EVM-compatible network and is currently not supported in MetaMask. We are hoping to facilitate support for Polkadot in the future through our Snaps plugin system.

See Polkadot's own information here

Articles in this section